Hello Neighbor Hide & Seek

Hello Neighbor Hide & Seek

By tinyBuild LLC

  • Category: Games
  • Release Date: 2018-12-06
  • Current Version: 1.2
  • Adult Rating: 9+
  • File Size: 944.38 MB
  • Developer: tinyBuild LLC
  • Compatibility: Requires Android / iOS 10.0 or later.
Score: 4
4
From 1,638 Ratings

Description

*Supported Devices: iPhone 6s, iPad 5 (2017), iPad Air 2, iPad Mini 2 or newer devices. iPod Touches are not supported* Hello Neighbor: Hide and Seek follows the tragic story of the Neighbor’s family in this dramatic prequel to Hello Neighbor. Experience playing a game of hide-and-seek with your brother as you both deal with a loss of a family member. The game explains events that lead up to the original Stealth Horror hit Hello Neighbor.

Advertisment

Screenshots

Reviews

  • Doesn’t support iPhone 6

    1
    By rikrozay
    Says it’s compatible with my phone but once again it is not
  • Compatibility Problems

    4
    By Wackytaxi359
    Hello. In your description, it says it supports iPad mini 2 and up. I’m playing on iPad mini 2, and when I open the game, it says “Sorry, this game does not support your device.” It doesn’t make any sense. Fix and I will rate 5 stars. Thanks.
  • Best game ever

    5
    By furryhatter
    I haven’t beat the game yet I think it’s better then normal hello neighbor i love this game it’s the best game ever thx for making it haters back off
  • Why didn’t it work on iPad

    2
    By hrhdhdhfhdhe
    It said chek the compandibl on the game page wean I did it
  • 😂😂😂😂

    1
    By chey chey😍
    Actually it is not compatible for phone what a let down 🤣🤣🤣🤣🤣
  • Huh?

    1
    By midgetgoat
    Says that my phone isn’t compatible but when I check in the App Store it is.
  • Says not compatible

    1
    By OCPawesome
    Can u plz make IPad Air 1 compatible
  • Yibanla

    1
    By hdjdksiwbshd
    It isn’t working on iPhone 6
  • Won’t work on phone

    3
    By rickytaylor2002
    I have a iPhone 6 and it still says not compatible
  • Doesn’t work

    1
    By awesomepoweraxe
    It doesn’t work but it that I am compatible

keyboard_arrow_up